Reply to Thread
Results 1 to 1 of 1

Thread: mayor drop refuses to work, wont build tavern

  1. #1
    Join Date
    May 2021

    mayor drop refuses to work, wont build tavern

    so i have this new settlers quest - level 3... ! but i cannot drag settlers over mayor

    the mayor does NOT light up. there is no icon of an item being dragged .. nothing.. i cant just click the mayor after in case the icon is invisible - no response

    then i get to the next drag quest - stones, pinewood etc.. and i cannot drop that either ??

    this is me hovering over mayor holding "10 settlers" -- but as you can see - there are no icons .. etc.. mayor is not glowing.. it gets marginally brighter only

    i get a quest to build a tavern - there again is no building icon - nothing to drop .. and again clicking any green space doesnt build .. the interaction just cancels.
    (in the pic you can see the cancel button - but no item to build).

    font scaling only applies to chat?? not to mayor tabs or email or?? anything else?? please return browser scaling which Works on everything!


    opera version is 76.0.4017.107 on win 10 (frankly the game will not open in any other browser i tried - ff, edge, chrome, slimjet - all cleared cache b4 tried)
    Last edited by Ciara_Belle; 16.05.21 at 10:58.

Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Ubisoft uses cookies to ensure that you get the best experience on our websites. By continuing to use this site you agree to accept these cookies. More info on our privacy.